Deutsch | English

Cross-Site-Scripting Schwachstelle in e-Learning Plattform Moodle

22. August 2012

CERT.at ersucht um Beachtung der folgenden Meldung.

Aufgrund der hohen Verbreitung der e-Learning Plattform Moodle haben wir uns entschlossen folgende Warnung herauszugeben.

Beschreibung

Wie z.B. auch SecurityFocus berichtet, wurde eine Sicherheitslücke in der e-Learning Plattform Moodle entdeckt, welche zumindest in der Version 2.2.1 existiert. Es handelt sich um eine Cross-Site-Scripting (XSS) Schwachstelle, welche u.a. zum Stehlen von Cookies genützt werden kann oder um (meist bösartige) Scripts von externen Seiten nachzuladen.

Auswirkungen

Ein Angreifer könnte durch das Ausnutzen dieser Schwachstelle die Cookies eines angemeldeten Benutzers ausspähen und unter Umständen Administrationsrechte erlangen. Weitere Szenarien, wie z.B. das Umleiten auf speziell präparierte Webseiten, sind auch denkbar.

Abhilfe

Die Entwickler von Moodle haben, für die mittlerweile veraltete Version 2.2.x, bereits einen Patch veröffentlicht (das aktuelle stable-Release von Moodle trägt die Versionsnummer 2.3.1).

Hinweis

Generell empfiehlt CERT.at, wo möglich ein Update von veralteten Versionen (<=2.2.x) auf das aktuellste stable-Release.
Informationsquelle(n):

Moodle Webseite
http://moodle.org/
Moodle Download
http://download.moodle.org/
SecurityFocus BugTraq
http://www.securityfocus.com/archive/1/523949
Email: reports@cert.at
Tel.: +43 1 5056416 78
mehr ...
Kritische Schwachstelle in bzip2 - je nach Setup für RCE ausnutzbar
24. Juni 2019 | Beschreibung In ...
Kritische RCE Schwachstelle in Oracle WebLogic Server
19. Juni 2019 | Beschreibung | Mehrere ...
mehr ...
Remote Desktop Services. Mal wieder.
14. August 2019 | Ich ...
BlueKeep, mal wieder
25. Juli 2019 | Das "Schöne" ...
mehr ...
Jahresbericht 2017
Ein Resumee zur digitalen Sicherheitslage in Österreich

(HTML, PDF).
Letzte Änderung: 2013/7/17 - 17:00:09
Haftungsausschluss / Datenschutzerklärung